[swift-evolution] [Accepted with revision] SE-0077 v2: Improved operator declarations

Joe Groff jgroff at apple.com
Thu Jul 7 17:42:41 CDT 2016

Proposal link: https://github.com/apple/swift-evolution/blob/master/proposals/0077-operator-precedence.md

The second review of SE-0077, "Improved operator declarations" ran from June 29 ... July 4, 2016. The proposal has been *accepted* with minor revisions. This round of feedback focused on naming, both of the attributes for precedence groups and the conventions to use for naming the groups themselves:

- The community expressed a strong preference for 'higherThan' and 'lowerThan' precedence relationships over the previously-proposed 'strongerThan' and 'weakerThan', and the core team *agrees* that these are better terms of art. The proposal is accepted with these terms revised.

- The standard library team reviewed the proposed names for the standard precedence groups, and suggests the following minor naming revisions:

> AssignmentPrecedence
> TernaryPrecedence
> DefaultPrecedence
> LogicalDisjunctionPrecedence
> LogicalConjunctionPrecedence
> ComparisonPrecedence
> NilCoalescingPrecedence
> CastingPrecedence
> RangeFormationPrecedence
> AdditionPrecedence
> MultiplicationPrecedence
> BitwiseShiftPrecedence

establishing a convention of <Noun>Precedence for precedence group names. The core team accepts the proposal with these revised standard precedence names.

Thanks Anton for shepherding this proposal through the review process!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160707/07dfd7d7/attachment.html>

More information about the swift-evolution mailing list