[swift-evolution] [Review] SE-0077 v2: Improved operator declarations

Dmitri Gribenko gribozavr at gmail.com
Thu Jul 7 11:28:33 CDT 2016

On Thu, Jul 7, 2016 at 9:27 AM, John McCall <rjmccall at apple.com> wrote:
> On Jul 7, 2016, at 9:23 AM, Dmitri Gribenko via swift-evolution
> <swift-evolution at swift.org> wrote:
>> Proposal link:
>> https://github.com/apple/swift-evolution/blob/master/proposals/0077-operator-precedence.md
> Dave, Max and I discussed SE-0077 and reviewed the names of precedence
> groups.
> Here's our recommendation.
> In general, we think some names don't read well and have some ambiguities,
> for
> example, "LogicalAndPrecedence" (looks like a conjunction),
> "AdditivePrecedence" ("additive" is an adjective that modifies
> "precedence"),
> "RangePrecedence" ("range" is not an adjective, stands out).
> We think that two directions would be fruitful:
> 1.  If the names of precedence groups will be in the same namespace as
> types,
>     then we recommend pushing the names of precedence groups into a
> "namespace",
>     for example "Precedence.Assignment".
> We don't have any language features that would allow this.

'precedencegroup' that is being proposed is a new language feature, we
can choose to use any syntax we like with it.


(j){printf("%d\n",i);}}} /*Dmitri Gribenko <gribozavr at gmail.com>*/

More information about the swift-evolution mailing list