[swift-evolution] [Discussion] Cleaning up stdlib pointer and buffer routines (Open Issues Affecting Standard Library API Stability)
Jordan Rose
jordan_rose at apple.com
Wed Jul 6 17:46:01 CDT 2016
> On Jul 6, 2016, at 11:03, Jacob Bandes-Storch via swift-evolution <swift-evolution at swift.org> wrote:
>
>
> * Remove unsafeAddressOf. "We are not aware of any real use cases for it. If there are any, it should be renamed to unsafeAddress(of:) to follow the guidelines." (https://bugs.swift.org/browse/SR-1957 <https://bugs.swift.org/browse/SR-1957> rdar://problem/18589289 <>)
>
>
> Oops, I just responded to this on another thread. Pasting:
>
> It's minor, but I use unsafeAddressOf regularly for writing `description` methods:
>
> var description: String {
> return "<\(self.dynamicType): \(unsafeAddressOf(self))>{ more info here... }"
> }
>
> I guess this would be covered by some generalized solution for format specifiers in string interpolations, but I gather that won't happen for quite a while...
I believe `ObjectIdentifier(self)` prints basically the same way.
Jordan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160706/09a13738/attachment.html>
More information about the swift-evolution
mailing list