[swift-evolution] [Discussion] Cleaning up stdlib pointer and buffer routines (Open Issues Affecting Standard Library API Stability)

Jacob Bandes-Storch jtbandes at gmail.com
Wed Jul 6 13:03:00 CDT 2016


> * *Remove unsafeAddressOf*. "We are not aware of any real use cases for
> it. If there are any, it should be renamed to unsafeAddress(of:) to follow
> the guidelines." (https://bugs.swift.org/browse/SR-1957
> rdar://problem/18589289)
>
>
Oops, I just responded to this on another thread. Pasting:

It's minor, but I use unsafeAddressOf regularly for writing `description`
methods:

    var description: String {
        return "<\(self.dynamicType): \(unsafeAddressOf(self))>{ more info
here... }"
    }

I guess this would be covered by some generalized solution for format
specifiers in string interpolations, but I gather that won't happen for
quite a while...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160706/ec163b14/attachment.html>


More information about the swift-evolution mailing list