[swift-evolution] Open Issues Affecting Standard Library API Stability

Jacob Bandes-Storch jtbandes at gmail.com
Wed Jul 6 13:01:24 CDT 2016


On Tue, Jul 5, 2016 at 10:50 PM, Dmitri Gribenko via swift-evolution <
swift-evolution at swift.org> wrote:

>
> > Remove unsafeAddressOf. We are not aware of any real usecases for it. If
> there are any, it should be renamed to unsafeAddress(of:) to follow the
> guidelines.
> Obvious, unless someone comes up with use cases during the review period.
>
>
It's minor, but I use unsafeAddressOf regularly for writing `description`
methods:

    var description: String {
        return "<\(self.dynamicType): \(unsafeAddressOf(self))>{ more info
here... }"
    }

I guess this would be covered by some generalized solution for format
specifiers in string interpolations, but I gather that won't happen for
quite a while...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160706/bd85db89/attachment.html>


More information about the swift-evolution mailing list