<div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">On Tue, Jul 5, 2016 at 10:50 PM, Dmitri Gribenko via swift-evolution <span dir="ltr"><<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
> Remove unsafeAddressOf. We are not aware of any real usecases for it. If there are any, it should be renamed to unsafeAddress(of:) to follow the guidelines.<br>
Obvious, unless someone comes up with use cases during the review period.<br>
<br></blockquote><div><br></div><div>It's minor, but I use unsafeAddressOf regularly for writing `description` methods:</div><div><br></div><div> var description: String {</div><div> return "<\(self.dynamicType): \(unsafeAddressOf(self))>{ more info here... }"</div><div> }</div><div><br></div><div>I guess this would be covered by some generalized solution for format specifiers in string interpolations, but I gather that won't happen for quite a while...</div></div></div></div>