[swift-evolution] [Review] SE-0101: Rename sizeof and related functions to comply with API Guidelines
scanon at apple.com
Fri Jul 1 07:05:11 CDT 2016
On Jun 30, 2016, at 9:12 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
> I don't believe that “stride” *is* the accepted term of art for this
> meaning. I never heard of the idea of types having an intrinsic
> “stride” until I arrived on the Swift project. That usage came from
> If you all swear up and down that you've been talking about “the stride
> of a type” for more than 2 years, I won't fight you on this.
> Otherwise... well, I still won't fight; I'm being crushed by an
> avalanche of bikesheds and I can't muster the energy ;->... but I'll
> forever be plagued by doubts about the name.
FWIW, speaking as someone with zero inside-baseball knowledge of Swift but a lot of low-level experience when I first encountered `strideof`, I thought its purpose was immediately obvious, and that it was (and is) a good name.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution