[swift-evolution] [Review] SE-0101: Rename sizeof and related functions to comply with API Guidelines

James Berry jberry at rogueorbit.com
Thu Jun 30 19:09:59 CDT 2016

> On Jun 30, 2016, at 4:59 PM, Erica Sadun <erica at ericasadun.com> wrote:
>> On Jun 30, 2016, at 5:47 PM, James Berry <jberry at rogueorbit.com <mailto:jberry at rogueorbit.com>> wrote:
>>> On Jun 30, 2016, at 4:05 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>>> on Thu Jun 30 2016, Erica Sadun <erica-AT-ericasadun.com <http://erica-at-ericasadun.com/>> wrote:
>>>>> On Jun 30, 2016, at 4:41 PM, Dave Abrahams <dabrahams at apple.com <mailto:dabrahams at apple.com>> wrote:
>>>>>> I mentioned this in a comment on the gist already, but I'm really not
>>>>>> digging the "array" in `arraySpacing`. We've already moved from top-level
>>>>>> "stride" to "memory layout spacing," gaining plenty of clarity. I'm
>>>>>> skeptical that the "array" adds anything more. Moreover, it muddies the
>>>>>> waters by mentioning a specific type (Array) in a context where you're
>>>>>> querying the memory layout properties of another type.
>>>>> OK, I agree with that.  If we have “alignment” rather than
>>>>> “defaultAlignment,” I suppose we can have plain “spacing.”
>>>> No way to last-second sell you on interval rather than spacing?
>>> If you can explain why it's better.
>>>> // Returns the least possible interval between distinct instances of
>>>> /// `T` in memory.  The result is always positive.
>>> For me, “interval” doesn't go with “size” and “alignment,” which are all
>>> about physical distances and locations.  There are all kinds of
>>> “intervals,” e.g. time intervals.
>> Hmm. Sounds like stride to me. stride or byteStride?
>> James
> FAQ: "Why aren't you using the obvious phrase `stride` for something that clearly 
> returns the memory stride?"
> ANSWER: "As stride already has a well-established meaning in the standard library,
> this proposal changes the name to spacing, providing a simple but correct name that
> works well enough in its intended use. Measuring memory is sufficiently esoteric
> that we prefer to reserve `stride` for a more common use case.”

Heh. Guess I missed that FAQ. Ok, so I guess I don’t agree with the answer. Yes, stride gets used as a verb in the library, but it seems more confusing to work around its meaning as a noun. Would I look like a duck if you asked me to duck?  ;)   “stride” is the appropriate term of the art here, and anything else just obscures the truth.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160630/8a9b993e/attachment.html>

More information about the swift-evolution mailing list