[swift-evolution] Request for quickie proposal and review

Erica Sadun erica at ericasadun.com
Tue Jun 28 21:32:11 CDT 2016


Dave:

I think this should be changed:

return withUnsafeMutablePointers { (v, e) in return body(v) }

should be

return withUnsafeMutablePointers { (h, e) in return body(h) }

-- E

> On Jun 28, 2016, at 8:04 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
> 
> 
> Hi,
> 
> It occurred to us a couple weeks ago that the name `Value` was
> a terrible name for the first parameter to `ManagedBuffer` et al, so I
> prepared this patch that renames it to `Header`.  
> 
> https://github.com/apple/swift/commit/eb7311de065df7ea332cdde8782cb44f9f4a5121
> 
> I would be immensely grateful if someone would like to volunteer to
> write up a quick proposal for this change and pushing it the process.
> 
> TIA,
> 
> -- 
> Dave
> 
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160628/dc4e7ed0/attachment.html>


More information about the swift-evolution mailing list