[swift-evolution] [Draft] Rationalizing Sequence end-operation names

Xiaodi Wu xiaodi.wu at gmail.com
Fri Jun 24 00:48:40 CDT 2016

On Fri, Jun 24, 2016 at 12:45 AM, Guillaume Lessard via swift-evolution <
swift-evolution at swift.org> wrote:

> I like this draft. Quickly:
> - “removing” sounds more destructive than “skipping”, so I’d lean towards
> using “skipping”. I would be happy with either, though.
> - there are two different labels for predicates (where and while). “where”
> is probably the better label. (some previous discussion had seemingly
> arrived to that conclusion:
> http://article.gmane.org/gmane.comp.lang.swift.evolution/16334/)

I think this is going to the distinction that "where" is now supposed to
correspond to "continue" inside a loop if the predicate isn't satisfied,
whereas "while" is supposed to correspond to "break" inside a loop if the
predicate isn't satisfied. Then again, I've argued elsewhere on this list
that the distinction isn't nearly as obvious as some seem to think it is,
and I think we have another demonstration of that here :)

> I like the idea of making the index-based slicing operations look more
> like slicing operations. I have on occasion wanted the operators you
> describe in the “aggressive” option; I approve.
> Cheers,
> Guillaume Lessard
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160624/5c15db63/attachment.html>

More information about the swift-evolution mailing list