[swift-evolution] [Draft] Rationalizing Sequence end-operation names

Guillaume Lessard glessard at tffenterprises.com
Fri Jun 24 00:45:30 CDT 2016

I like this draft. Quickly:

- “removing” sounds more destructive than “skipping”, so I’d lean towards using “skipping”. I would be happy with either, though.
- there are two different labels for predicates (where and while). “where” is probably the better label. (some previous discussion had seemingly arrived to that conclusion: http://article.gmane.org/gmane.comp.lang.swift.evolution/16334/)

I like the idea of making the index-based slicing operations look more like slicing operations. I have on occasion wanted the operators you describe in the “aggressive” option; I approve.

Guillaume Lessard

More information about the swift-evolution mailing list