[swift-evolution] [Review] SE-0101: Rename sizeof and related functions to comply with API Guidelines

Erica Sadun erica at ericasadun.com
Tue Jun 21 19:26:04 CDT 2016

> On Jun 21, 2016, at 6:06 PM, Dave Abrahams <dabrahams at apple.com> wrote:
> It's just that I don't think this part of the library API is important
> enough, to enough people, that this readability is worth the additional
> exposed surface area (and further exposure later on—I can easily imagine
> a “minimumAlignment”).  I would *much* rather keep this stuff corralled
> in a single namespace where it can all be found.

See? That, I totally get.

> I think you represented it just fine, thanks... I just don't think
> you're accounting for the big picture.  These APIs are not like “map,”
> “filter,” and “Dictionary.”  They're specialty items that you should
> only reach for when performing unsafe operations, mostly inside the guts
> of higher-level constructs.
> -- 
> Dave

Would you like me to edit it and flip the proposal then? Put the MemoryLayout in as primary,
mine as secondary, and add in text to explain that the motivation is less usability than serving
an unsafe API with minimal surface area?

-- E

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160621/060a21a0/attachment.html>

More information about the swift-evolution mailing list