[swift-evolution] [Review] SE-0101: Rename sizeof and related functions to comply with API Guidelines
david at alkaline-solutions.com
Tue Jun 21 19:21:58 CDT 2016
> On Jun 21, 2016, at 6:06 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
> on Tue Jun 21 2016, Erica Sadun <erica-AT-ericasadun.com <http://erica-at-ericasadun.com/>> wrote:
>> and we're unlikely to convince each other on-list, which is why I
>> tried hard to make sure that your alternative was properly presented
>> in the proposal. If I have made any errors in expressing your design,
>> its intent, and rationale, please let me know and I will edit the
>> proposal to fix.
> I think you represented it just fine, thanks... I just don't think
> you're accounting for the big picture. These APIs are not like “map,”
> “filter,” and “Dictionary.” They're specialty items that you should
> only reach for when performing unsafe operations, mostly inside the guts
> of higher-level constructs.
Late arrival to the thread, but wouldn’t these make sense to move these closer to the ‘Indexable’ Pointer/Buffer types, possibly onto them as static methods?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution