[swift-evolution] [swift-evolution-announce] [Review] SE-0099: Restructuring Condition Clauses
Charlie Monroe
charlie at charliemonroe.net
Sun May 29 06:26:04 CDT 2016
> On 28 May 2016, at 23:48, Chris Lattner via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
>
>
>> On May 27, 2016, at 12:11 PM, Joe Groff <jgroff at apple.com <mailto:jgroff at apple.com>> wrote:
>>
>> Hello Swift community,
>>
>> The review of SE-0099 “Restructuring Condition Clauses” begins now and runs through June 3, 2016. The proposal is available here:
>>
>> https://github.com/apple/swift-evolution/blob/master/proposals/0099-conditionclauses.md <https://github.com/apple/swift-evolution/blob/master/proposals/0099-conditionclauses.md>
> Thanks everyone. FYI, Erica and I discussed it offlist and agreed to amend the proposal: now you can use semicolons or a newline to separate clauses of different types.
I just don't understand why there are large fractions of the community, fighting to have a uniform syntax without any dialects, not being in favor of e.g. an optional warning to enforce explicit self, which could prevent people from bugs, yet then a proposal with three (!) allowed syntax variations is introduced.
The `where` clause improved readability - it might not have had anything to do syntactically with the optional binding, but it usually made some kind of sense:
guard let myPoint = view.calculateSomePoint() where view.isVisible else { ... }
Seems perfectly reasonable and much more readable than
guard let myPoint = view.calculateSomePoint(); view.isVisible else { ... }
-1 for me.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160529/35e180f6/attachment.html>
More information about the swift-evolution
mailing list