<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><br class=""><div><div class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div class=""><blockquote type="cite" class=""><div class="">On 28 May 2016, at 23:48, Chris Lattner via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org" class="">swift-evolution@swift.org</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html charset=utf-8" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><br class=""><div class=""><blockquote type="cite" class=""><div class="">On May 27, 2016, at 12:11 PM, Joe Groff &lt;<a href="mailto:jgroff@apple.com" class="">jgroff@apple.com</a>&gt; wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html charset=utf-8" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">Hello Swift community,<br class=""><br class="">The review of SE-0099 “Restructuring Condition Clauses” begins now and runs through June 3, 2016. The proposal is available here:<br class=""><br class=""><span class="Apple-tab-span" style="white-space:pre">        </span><a href="https://github.com/apple/swift-evolution/blob/master/proposals/0099-conditionclauses.md" class="">https://github.com/apple/swift-evolution/blob/master/proposals/0099-conditionclauses.md</a></div></div></blockquote></div><br class=""><div class="">Thanks everyone. &nbsp;FYI, Erica and I discussed it offlist and agreed to amend the proposal: now you can use semicolons or a newline to separate clauses of different types.</div></div></div></blockquote></div></div></div><div><br class=""></div><div>I just don't understand why there are large fractions of the community, fighting to have a uniform syntax without any dialects, not being in favor of e.g. an optional warning to enforce explicit self, which could prevent people from bugs, yet then a proposal with three (!) allowed syntax variations is introduced.</div><div><br class=""></div><div>The `where` clause improved readability - it might not have had anything to do syntactically with the optional binding, but it usually made some kind of sense:</div><div><br class=""></div><div>guard let myPoint = view.calculateSomePoint() where view.isVisible else { ... }</div><div><br class=""></div><div>Seems perfectly reasonable and much more readable than</div><div><br class=""></div><div>guard let myPoint = view.calculateSomePoint(); view.isVisible else { ... }</div><div><br class=""></div><div>-1 for me.</div><div><br class=""></div></div></body></html>