[swift-evolution] RFC: didset and willset
matthew at anandabits.com
Fri May 20 13:50:39 CDT 2016
> On May 20, 2016, at 1:30 PM, Xiaodi Wu <xiaodi.wu at gmail.com> wrote:
> On Fri, May 20, 2016 at 1:16 PM, Matthew Johnson via swift-evolution <swift-evolution at swift.org <mailto:swift-evolution at swift.org>> wrote:
> > On May 20, 2016, at 12:41 PM, Chris Lattner <clattner at apple.com <mailto:clattner at apple.com>> wrote:
> > On May 20, 2016, at 7:26 AM, Matthew Johnson <matthew at anandabits.com <mailto:matthew at anandabits.com>> wrote:
> >>> (For instance, a perhaps controversial opinion: I think `dynamicType` is properly capitalized for the syntactic slot it's in. That's not to say I think we should *keep* `dynamicType`, but simply that `foo.dynamicType` is more appropriate than `foo.dynamictype` would be.)
> >> +1. 'foo.dynamictype' seems strange to me.
> > foo.dynamicType is broken for other reasons. I see x.dynamicType as being a named operator (like sizeof) and not a property. For example, we don’t want .dynamicType to show up in code completion on every value in the universe ("4.dynamicType”, really?).
> > That argues that it should be spelled as dynamicType(x), and ideally being a standard library feature instead of a keyword.
> That makes sense. It never crossed my mind until now, but given that `sizeof` is a standard library feature why isn’t it camel case `sizeOf`? Is this a case of “term of the art”?
> See: http://thread.gmane.org/gmane.comp.lang.swift.evolution/15830/ <http://thread.gmane.org/gmane.comp.lang.swift.evolution/15830/>
Thanks. That’s what I figured. :)
> > -Chris
> swift-evolution mailing list
> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution