[swift-evolution] RFC: didset and willset
xiaodi.wu at gmail.com
Fri May 20 13:30:01 CDT 2016
On Fri, May 20, 2016 at 1:16 PM, Matthew Johnson via swift-evolution <
swift-evolution at swift.org> wrote:
> > On May 20, 2016, at 12:41 PM, Chris Lattner <clattner at apple.com> wrote:
> > On May 20, 2016, at 7:26 AM, Matthew Johnson <matthew at anandabits.com>
> >>> (For instance, a perhaps controversial opinion: I think `dynamicType`
> is properly capitalized for the syntactic slot it's in. That's not to say I
> think we should *keep* `dynamicType`, but simply that `foo.dynamicType` is
> more appropriate than `foo.dynamictype` would be.)
> >> +1. 'foo.dynamictype' seems strange to me.
> > foo.dynamicType is broken for other reasons. I see x.dynamicType as
> being a named operator (like sizeof) and not a property. For example, we
> don’t want .dynamicType to show up in code completion on every value in the
> universe ("4.dynamicType”, really?).
> > That argues that it should be spelled as dynamicType(x), and ideally
> being a standard library feature instead of a keyword.
> That makes sense. It never crossed my mind until now, but given that
> `sizeof` is a standard library feature why isn’t it camel case `sizeOf`?
> Is this a case of “term of the art”?
> > -Chris
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution