[swift-evolution] [Accepted with Revision] SE-0088: Modernize libdispatch for Swift 3 naming conventions

Chris Lattner clattner at apple.com
Thu May 19 23:49:00 CDT 2016

> On May 19, 2016, at 9:02 PM, Patrick Smith <pgwsmith at gmail.com> wrote:
> Great stuff! Truly is a massive improvement to an already venerable API.
> Was there any consideration to make this a new module ‘Dispatch’, and drop all the Dispatch- prefixes? Or rather, what is the reason for keeping the prefixes? (Group could become WorkGroup to lessen naming conflicts)

We discussed it briefly, but Swift currently lacks a developed model for submodules, and tackling it should only be done with a holistic design.  If/when we introduce them and adapt dispatch to use them, we believe that we can do so without massive impact to users code (we can phase it in over time).


More information about the swift-evolution mailing list