[swift-evolution] [Accepted with Revision] SE-0088: Modernize libdispatch for Swift 3 naming conventions

Jacob Bandes-Storch jtbandes at gmail.com
Thu May 19 23:07:00 CDT 2016


This is great!

What will setTargetQueue and setTimer become? It would be great if the
proposal doc could be updated with the API that was accepted.
On Thu, May 19, 2016 at 9:03 PM Patrick Smith via swift-evolution <
swift-evolution at swift.org> wrote:

> Great stuff! Truly is a massive improvement to an already venerable API.
>
> Was there any consideration to make this a new module ‘Dispatch’, and drop
> all the Dispatch- prefixes? Or rather, what is the reason for keeping the
> prefixes? (Group could become WorkGroup to lessen naming conflicts)
>
>
> > On 20 May 2016, at 1:57 PM, Chris Lattner via swift-evolution <
> swift-evolution at swift.org> wrote:
> >
> > Proposal link:
> https://github.com/apple/swift-evolution/blob/master/proposals/0088-libdispatch-for-swift3.md
> >
> > Hello Swift Community,
> >
> > The review of "SE-0088: Modernize libdispatch for Swift 3 naming
> conventions" ran from May 10…17, 2016. The proposal is *accepted with
> revisions* for Swift 3.
> >
> > The community and core team are both very positive about this massive
> improvement to the libdispatch APIs.  Much of the discussion has centered
> around specific details in the proposal - for example the “.asynchronously”
> method on DispatchQueue.  This great discussion leads to several requested
> revisions in the proposal:
> >
> > - Rename the DispatchQueue.[a]synchronously methods to ".async” and
> ".sync”, to follow the term of art.
> > - Rename DispatchIO setHighWater, setLowWater --> setLimit(highWater:),
> setLimit(lowWater:)
> > - Rename setTargetQueue(queue:) and DispatchSource.setTimer
> > - Rename Semaphore, Group and WorkItem: .wait(timeout:) --> wait() and
> wait(withTimeout:)
> > - Expand source handler methods to take the same arguments as async()
> > - Expand DispatchQueue.after to take the same arguments as async() in
> addition to the when: argument
> >
> > Thank you to Matt Wright proposing this, and for all of the
> implementation work that has gone into this so far!
> >
> > -Chris Lattner
> > Review Manager
> >
> > _______________________________________________
> > swift-evolution mailing list
> > swift-evolution at swift.org
> > https://lists.swift.org/mailman/listinfo/swift-evolution
>
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160520/d133432a/attachment.html>


More information about the swift-evolution mailing list