[swift-evolution] Trial balloon: conforming sizeof, sizeofValue, etc. to naming guidelines
brent at architechies.com
Sun May 1 04:54:58 CDT 2016
> With the renaming proposed above, stride(of:) will appear to be related to stride(from:to:by:). This conflict arises from a pre-existing issue; namely, the term "stride" is used to mean two different things. Although moving the preposition only highlights the issue, one possible resolution is to rename strideof(_:) to strideSize(of:) and strideofValue(_:) tostrideSize(ofValue:).
I wonder if it might make sense to rename all of these, then?
More information about the swift-evolution