[swift-evolution] [Proposal draft] Enhanced floating-point protocols

davesweeris at mac.com davesweeris at mac.com
Mon Apr 18 17:28:56 CDT 2016


> On Apr 16, 2016, at 6:12 PM, Howard Lovatt via swift-evolution <swift-evolution at swift.org> wrote:
> 
> For the Arithmetic protocol how about changing it to:
> 
>     protocol Arithmetic {
>         func + (lhs: Self, rhs: Self) -> Self
>         mutating func += (rhs: Self) -> Self
>         ...
>     }
> 
> That way naming issues are largely avoided, except for `mutating func negate()` which has no operator and would therefore have to be a normal, non-operator, func. 
“prefix -" works for negate, at least off the top of my head.

I think.

- Dave Sweeris
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160418/240b0377/attachment.html>


More information about the swift-evolution mailing list