<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><div><blockquote type="cite" class=""><div class="">On Apr 16, 2016, at 6:12 PM, Howard Lovatt via swift-evolution <<a href="mailto:swift-evolution@swift.org" class="">swift-evolution@swift.org</a>> wrote:</div><br class="Apple-interchange-newline"><div class="">For the Arithmetic protocol how about changing it to:<div class=""><br class=""></div><div class=""> protocol Arithmetic {</div><div class=""> func + (lhs: Self, rhs: Self) -> Self</div><div class=""><font size="2" class=""><span style="background-color:rgba(255,255,255,0)" class=""> mutating func += (rhs: Self) -> Self</span></font></div><div class=""><font size="2" class=""><span style="-webkit-tap-highlight-color: rgba(26, 26, 26, 0.301961);" class=""> ...</span></font></div><div class=""><font size="2" class=""><span style="-webkit-tap-highlight-color: rgba(26, 26, 26, 0.301961);" class=""> }</span></font></div><div class=""><font size="2" class=""><span style="-webkit-tap-highlight-color: rgba(26, 26, 26, 0.301961);" class=""><br class=""></span></font></div><div class=""><font size="2" class=""><span style="-webkit-tap-highlight-color: rgba(26, 26, 26, 0.301961);" class="">That way naming issues are largely avoided, except for `mutating func negate()` which has no operator and would therefore have to be a normal, non-operator, <span class=""></span>func. <br class=""></span></font></div></div></blockquote></div>“prefix -" works for negate, at least off the top of my head.<div class=""><br class=""></div><div class="">I think.<br class=""><div class=""><br class=""></div><div class="">- Dave Sweeris</div></div></body></html>