[swift-evolution] [SR-933] Rename flatten to flattened
howard.lovatt at gmail.com
Wed Apr 13 18:27:22 CDT 2016
With regard to trig they are functions:
let s = sin(x)
so not really relevant. But if the were made members then:
let s = x.sined
Would read well.
On Tuesday, 12 April 2016, Brent Royal-Gordon via swift-evolution <
swift-evolution at swift.org> wrote:
> >> Do you also think that trigonometry should be `foo.sined`,
> `foo.cosined`, and `foo.tangented`?
> > sine, cosine etc. are all nouns so I think as computed properties they’d
> be fine as is?
> So you would favor these?
> _ = number.sine()
> _ = number.cosine()
> _ = number.tangent()
> Brent Royal-Gordon
> swift-evolution mailing list
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution