With regard to trig they are functions:<div><br></div><div> let s = sin(x)</div><div><br></div><div>so not really relevant. But if the were made members then:</div><div><br></div><div>  let s = x.sined</div><div>  x.sin()</div><div><br></div><div>Would read well. <span></span><br><br>On Tuesday, 12 April 2016, Brent Royal-Gordon via swift-evolution &lt;<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>&gt; wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">&gt;&gt; Do you also think that trigonometry should be `foo.sined`, `foo.cosined`, and `foo.tangented`?<br>
&gt;<br>
&gt; sine, cosine etc. are all nouns so I think as computed properties they’d be fine as is?<br>
<br>
So you would favor these?<br>
<br>
        _ = number.sine()<br>
        _ = number.cosine()<br>
        _ = number.tangent()<br>
<br>
        number.formSine()<br>
        number.formCosine()<br>
        number.formTangent()<br>
<br>
--<br>
Brent Royal-Gordon<br>
Architechies<br>
<br>
_______________________________________________<br>
swift-evolution mailing list<br>
<a href="javascript:;" onclick="_e(event, &#39;cvml&#39;, &#39;swift-evolution@swift.org&#39;)">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div><br><br>-- <br>-- Howard.<br>