[swift-evolution] [Review] SE-0059: Update API Naming Guidelines and Rewrite Set APIs Accordingly
brent at architechies.com
Sat Apr 2 16:15:38 CDT 2016
> For example, changing union() to formUnion() for the sake of aligning compliance to API name guidelines simply doesn't make sense to me.
Given the need for separate names for the functional and imperative forms of this operation, what sorts of names would be better? Pseudo-verbs like `unioning`? An `InPlace` suffix?
(Everyone else, please don't take this as an invitation to start the bikeshedding again. I'm trying to understand what *this reviewer* prefers.)
More information about the swift-evolution