[swift-evolution] SetAlgebra naming update

Thorsten Seitz tseitz42 at icloud.com
Wed Mar 30 10:05:35 CDT 2016

> Am 30.03.2016 um 16:49 schrieb Dave Abrahams <dabrahams at apple.com>:
>> on Wed Mar 30 2016, Thorsten Seitz <tseitz42-AT-icloud.com> wrote:
>> That's certainly an improvement, but why "formIntersection" instead of
>> "intersect" (in analogy to "subtract")?
> 1. Consistency with union, which is more closely related than subtract.

I'd prefer consistency with the verb rule here (using formXXX only as last resort).

> 2. "Intersect" actually has the wrong meaning as an imperative.  If you
>   tell set A to intersect set B, and then ask whether A intersects B
>   (!A.isDisjoint(with: B)), you would expect an answer of true.

Sorry, but I do not agree. With that reasoning I would have to expect a.intersection(b) to be not empty. 


More information about the swift-evolution mailing list