[swift-evolution] SetAlgebra naming update
Dave Abrahams
dabrahams at apple.com
Wed Mar 30 09:49:51 CDT 2016
on Wed Mar 30 2016, Thorsten Seitz <tseitz42-AT-icloud.com> wrote:
> That's certainly an improvement, but why "formIntersection" instead of
> "intersect" (in analogy to "subtract")?
1. Consistency with union, which is more closely related than subtract.
2. "Intersect" actually has the wrong meaning as an imperative. If you
tell set A to intersect set B, and then ask whether A intersects B
(!A.isDisjoint(with: B)), you would expect an answer of true.
>
> -Thorsten
>
> Am 30. März 2016 um 00:07 schrieb "T.J. Usiyan via swift-evolution" <swift-evolution at swift.org>:
>
> I think that this is a great improvement and is consistent enough to accept. `form` will take some getting used to.
> TJ
>
> On Thu, Mar 24, 2016 at 9:39 PM, Dave Abrahams via swift-evolution <swift-evolution at swift.org> wrote:
>
> Just an update:
>
> The naming guidelines working group went back into negotiation over
> the shape of SetAlgebra (and thus, Set and OptionSet) for
> Swift 3, and reached a new consensus. We intend to bring forward a
> proposal for the API shown here:
>
> http://dabrahams.github.io/swift-naming/SetAlgebra-Math.html
>
> and to update the guidelines to suggest using the "form" prefix to
> create a verb phrase for a mutating method when the operation is
> fundamentally non-mutating and described by a noun.
>
> Regards,
>
> --
> Dave
>
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
>
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution
>
--
Dave
More information about the swift-evolution
mailing list