[swift-evolution] SetAlgebra naming update

davesweeris at mac.com davesweeris at mac.com
Mon Mar 28 19:19:44 CDT 2016

> On Mar 25, 2016, at 4:45 PM, Dave Abrahams <dabrahams at apple.com> wrote:
> on Fri Mar 25 2016, davesweeris-AT-mac.com wrote:
>> Can we rename `subtract` to `complement`, since that’s the correct
>> term? At least, I’m assuming that’s what `subtract` means… if not, I’m
>> confused.
>> https://en.wikipedia.org/wiki/Set_(mathematics)#Complements
> It's not just “complement,” because that means inverting set membership
> of everything in a finite domain.  It would have to be “relative
> complement.”  But “relative complement” lacks the directional
> implication that plagues terms like “difference,” but not “subtracting.”

Fair points… I accidentally left off the argument label. May I amend my suggestion to "rename `subtract(:)` to `complement(relativeTo:)`”? It just seems to me that if we’re going to claim we’re implementing something, we should adopt as much of its “standard" syntax and terminology as possible. It makes Swift easier to use for those coming from other disciplines, IMHO.

- Dave Sweeris

More information about the swift-evolution mailing list