[swift-evolution] Update the signature of ObjectiveC.autoreleasepool [SR-842]

Timothy Wood tjw at me.com
Mon Mar 28 18:27:15 CDT 2016

> On Mar 24, 2016, at 8:37 AM, Timothy J. Wood via swift-evolution <swift-evolution at swift.org> wrote:
> If `autoreleasepool` is turned into a statement instead of a function, the meaning of existing code will silently change in possibly disastrous and hard to detect ways. Is there a plan in place to deal with this? The only idea that occurs to me would be to leave `autoreleasepool` as is for a transitional time, deprecated, and add a statement with a new name. Though, if a newly named statement were to be added, then we’re back to being able to leave `autoreleasepool` as a function with a return value and error =)

Is there any further concern about leaving autoreleasepool() as a function? I’m not sure what the next step in this proposal should be -- should I note this concern in the proposal, or does it need to be resolved before there is further progress?



More information about the swift-evolution mailing list