[swift-evolution] swift-evolution Digest, Vol 4, Issue 35
ilya.belenkiy at gmail.com
Tue Mar 15 08:02:35 CDT 2016
These are very nice and short names. I think that private and private(X) is
better though because it's obvious that it's about access level and not
something else (like a variable name or some other thing). These words need
more context while private(x) doesn't.
On Tue, Mar 15, 2016 at 8:48 AM Patrick Smith via swift-evolution <
swift-evolution at swift.org> wrote:
> What if private was just removed, and instead just has a literal
> description of where the member is accessible from?
> public var something: Int
> module var something: Int
> file var something: Int
> scope var something: Int
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution