<div style="white-space:pre-wrap">These are very nice and short names. I think that private and private(X) is better though because it's obvious that it's about access level and not something else (like a variable name or some other thing). These words need more context while private(x) doesn't.</div><br><div class="gmail_quote"><div dir="ltr">On Tue, Mar 15, 2016 at 8:48 AM Patrick Smith via swift-evolution <<a href="mailto:swift-evolution@swift.org">swift-evolution@swift.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div style="padding-left:16px;padding-right:16px;padding-bottom:8px"><div>What if private was just removed, and instead just has a literal description of where the member is accessible from?</div><div><br></div><div><br></div><div>public var something: Int</div><div><br></div><div>module var something: Int</div><div><br></div><div>file var something: Int</div><div><br></div><div>scope var something: Int</div><div><br></div><div><br></div><div><br></div><div>Patrick</div></div>
_______________________________________________<br>
swift-evolution mailing list<br>
<a href="mailto:swift-evolution@swift.org" target="_blank">swift-evolution@swift.org</a><br>
<a href="https://lists.swift.org/mailman/listinfo/swift-evolution" rel="noreferrer" target="_blank">https://lists.swift.org/mailman/listinfo/swift-evolution</a><br>
</blockquote></div>