[swift-evolution] [Pitch] Introducing #fileName debug identifier
erica at ericasadun.com
Mon Mar 14 15:49:55 CDT 2016
> On Mar 14, 2016, at 2:37 PM, Chris Lattner <clattner at apple.com> wrote:
> If it is practical to get the module-relative path, I’d rather see us switch #file to produce *that*, and introduce a #fullPath that produces the current behavior. Rationale: we want to encourage deterministic and stable builds wherever possible, and including the full path to a source file breaks the ability to build in different directories (e.g. two different users’s homedirs) and get the same executable out.
I'd like to know one way or another. My current understanding is that this is not produced as part of the build.
And, quite honestly, I'd sort of like to see better names. I stuck with file, line, column, and function because those were the current art.
Now that the identifiers are growing, relativeFilePath, fullFilePath, fileName, lineNumber (or fileLineNumber), fileColumn, and functionSignature (that's somehow compliant with the updated signatures proposal) seem more appropriate. The old "function" string just feels archaic and wrong.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution