[swift-evolution] [Idea] Make Boolean @objc properties reflect better into Objective-C

Dave Abrahams dabrahams at apple.com
Tue Feb 23 16:25:32 CST 2016

on Tue Feb 23 2016, Douglas Gregor <swift-evolution at swift.org> wrote:

> My proposal is to strip the “is” prefix from the Objective-C name, but leave it off the getter, e.g.,
> 	@property (readwrite,nonatomic,getter=isEnabled) BOOL enabled;
> The change would have no effect on the Swift name; it will only affect the Objective-C property name and setter name.
> Thoughts?


More information about the swift-evolution mailing list