[swift-evolution] ed/ing, InPlace, Set/SetAlgebra naming resolution

Greg Parker gparker at apple.com
Thu Feb 11 17:57:45 CST 2016

> On Feb 11, 2016, at 3:54 PM, Xiaodi Wu via swift-evolution <swift-evolution at swift.org> wrote:
> This is an interesting bit of historical perspective. Dave--may I ask
> a naive question?
> The proposal as shown is extensive. Would it be within reach/easier to
> pitch/feasible to implement a narrower set of changes to facilitate
> naming convention only? Namely: alter Swift syntax to allow function
> names to begin with "=" and adopt naming conventions that
> mutating/non-mutating pairs of functions are named
> =frobnicate()/frobnicate()? That would, it seems, go a long way.

That would not be a small change. The strict separation between operator characters and non-operator characters is deeply embedded into Swift's grammar and compiler.

Greg Parker     gparker at apple.com     Runtime Wrangler

More information about the swift-evolution mailing list