[swift-evolution] ed/ing, InPlace, Set/SetAlgebra naming resolution

Xiaodi Wu xiaodi.wu at gmail.com
Thu Feb 11 17:54:19 CST 2016

This is an interesting bit of historical perspective. Dave--may I ask
a naive question?

The proposal as shown is extensive. Would it be within reach/easier to
pitch/feasible to implement a narrower set of changes to facilitate
naming convention only? Namely: alter Swift syntax to allow function
names to begin with "=" and adopt naming conventions that
mutating/non-mutating pairs of functions are named
=frobnicate()/frobnicate()? That would, it seems, go a long way.

On Thu, Feb 11, 2016 at 5:17 PM, Dave Abrahams via swift-evolution
<swift-evolution at swift.org> wrote:
> For the record, I do not feel at all confident anything like this will
> end up in swift.  This feature was proposed back in 2013, before Swift
> was released, eventually accepted then not implemented because we were
> out of time, then revised, then re-accepted and implemented, then ripped
> out of the compiler because of various concerns about what it does to
> the shape of the language (e.g. is this just a second version of
> “mutating?”  What about classes?).  Based on history, I don't think it's
> a sure bet, and I personally may be out of energy and time to fight for
> it.  But we'll have to see...

More information about the swift-evolution mailing list