[swift-evolution] [Proposal draft #2] Naming Functions with Argument Labels
David Owens II
david at owensd.io
Mon Jan 11 15:42:38 CST 2016
I like the proposal. It does illustrate one of the naming conventions I really dislike with Swift (implicitly unnamed first parameter).
> let fn1 = someView.insert(subview:aboveSubview:)
Would have looked so much better. =)
Anyhow, +1 for the proposal.
> On Jan 11, 2016, at 11:03 AM, Douglas Gregor via swift-evolution <swift-evolution at swift.org> wrote:
> Hi all,
> I’ve updated and simplified my “Generalized Naming for Any Function” proposal to only deal with naming functions with argument labels, and dropping the back-ticks. Comments welcome! Proposal is here
> https://github.com/DougGregor/swift-evolution/blob/generalized-naming/proposals/0000-generalized-naming.md <https://github.com/DougGregor/swift-evolution/blob/generalized-naming/proposals/0000-generalized-naming.md>
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution