[swift-evolution] [Proposal]: Rectangles and other common structures.

Charles Constant charles at charlesism.com
Thu Jan 7 01:54:26 CST 2016


> CGRectIntegral

But that's conversion though, right? That's part of what I find stressful.
If I'm using Ints internally, I don't ever need to worry about getting
wonky results because of floating point math.

On Wed, Jan 6, 2016 at 11:45 PM, John Randolph <jcr at icloud.com> wrote:

>
> > On Jan 6, 2016, at 11:38 PM, Charles Constant <charles at charlesism.com>
> wrote:
> >
> > > I can certainly think of situations where I might want integer based
> rectangles, sizes, and points.
> >
> > I'm quite biased this week, because I spent *yesterday* writing a file
> for my project with "IntRect" "IntPoint" "IntSize" ad nauseam. It's not
> something I'm very thrilled to have as part of my Audio app - a lone file
> of geometric structs that aready exist if you use CGFloats, where I don't
> get the full implementation, etc. And previously, I've written code that I
> needed land on whole numbers, and the extra concern about finding the right
> options in Cocoa to do so just stressed me out.
>
> FWIW, NSIntegralRect() and CGRectIntegral() do exist.  Note their entirely
> different naming conventions.  ;-)
>
> Would be much nicer to just use myRect.integralRect when I need to round
> it.  Might also be nice to have myRect.roundedOut and myRect.roundedIn for
> a bit more control of which way the sides move.
>
> -jcr
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20160106/5b47e82f/attachment.html>


More information about the swift-evolution mailing list