[swift-evolution] [Proposal]: Rectangles and other common structures.

John Randolph jcr at icloud.com
Thu Jan 7 01:45:29 CST 2016


> On Jan 6, 2016, at 11:38 PM, Charles Constant <charles at charlesism.com> wrote:
> 
> > I can certainly think of situations where I might want integer based rectangles, sizes, and points.
> 
> I'm quite biased this week, because I spent *yesterday* writing a file for my project with "IntRect" "IntPoint" "IntSize" ad nauseam. It's not something I'm very thrilled to have as part of my Audio app - a lone file of geometric structs that aready exist if you use CGFloats, where I don't get the full implementation, etc. And previously, I've written code that I needed land on whole numbers, and the extra concern about finding the right options in Cocoa to do so just stressed me out.  

FWIW, NSIntegralRect() and CGRectIntegral() do exist.  Note their entirely different naming conventions.  ;-)

Would be much nicer to just use myRect.integralRect when I need to round it.  Might also be nice to have myRect.roundedOut and myRect.roundedIn for a bit more control of which way the sides move.

-jcr




More information about the swift-evolution mailing list