[swift-evolution] Thoughts on clarity of Double and Float type names?
cantrell at pobox.com
Tue Jan 5 15:10:27 CST 2016
In principle, having Float, Float32, and Float64 and no “Double” at all seems highly sensible to me.
In practice, the migration cost of changing the meaning of Float from “32-bit” to “platform preferred size” seems like a potential deal-killer.
> On Jan 5, 2016, at 2:25 PM, Alex Johnson via swift-evolution <swift-evolution at swift.org> wrote:
> Just to clarify: I was suggesting removing the name "Double" and giving a different meaning to the name "Float".
> ~ Alex
> On Tue, Jan 5, 2016 at 11:51 AM, Chris Lattner <clattner at apple.com <mailto:clattner at apple.com>> wrote:
> These are functionally different cases. We are *omitting* a C feature by removing ++ and --. This proposal included keeping the name “Double” but giving it a different meaning.
> swift-evolution mailing list
> swift-evolution at swift.org
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-evolution