[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"
glessard at tffenterprises.com
Tue Dec 22 20:55:25 CST 2015
> On 22 déc. 2015, at 19:01, Douglas Gregor via swift-evolution <swift-evolution at swift.org> wrote:
>> On Dec 22, 2015, at 11:05 AM, Matt Whiteside via swift-evolution <swift-evolution at swift.org> wrote:
>> “parameter” is a good thought. On it’s own it seems like it’s missing something though. But it gives me other ideas: “typeparam”, “type param", “typeparameter”, or “type parameter”.
> It’s not a parameter, though, because it does not vary the way a parameter does: a given type X cannot conform to a protocol with two different bindings for a given associated type.
Well, in the context of a generic function or generic type, we have “type parameter” and “generic parameter clauses”. Is a protocol's associated type truly so different that it requires a different name? Note that many people out there are calling a protocol-with-associated-type a “generic protocol”.
More information about the swift-evolution