[swift-evolution] [SE-0011] Re-considering the replacement keyword for "typealias"

Matt Whiteside mwhiteside.dev at gmail.com
Tue Dec 22 13:05:32 CST 2015

“parameter” is a good thought.  On it’s own it seems like it’s missing something though.  But it gives me other ideas: “typeparam”, “type param", “typeparameter”, or “type parameter”.


> On Dec 22, 2015, at 07:40, Guillaume Lessard via swift-evolution <swift-evolution at swift.org> wrote:
>> On 21 déc. 2015, at 17:57, Jordan Rose via swift-evolution <swift-evolution at swift.org> wrote:
>> When you're actually implementing a generic function, the generic parameter is [snip]
> Here's a word with meaning: parameter. Everything else I've seen sounds vague or approximate. Using the idea of a parameter would solidify the conceptual relationship between protocols-with-associated-types and generics.
> protocol P {
>  parameter T
> }
> Guillaume Lessard
> _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org
> https://lists.swift.org/mailman/listinfo/swift-evolution

More information about the swift-evolution mailing list