[swift-evolution] Proposal for Replacing Keyword "subscript" with "subs"‏

Jack Lawrence jackl at apple.com
Thu Dec 10 20:22:55 CST 2015


It’s non-obvious to me that “subs” is short for subscript, whereas “init” and “func” have only one obvious expansion.

Jack 
> On Dec 10, 2015, at 6:12 PM, Feijian Sun via swift-evolution <swift-evolution at swift.org> wrote:
> 
> Hello, 
> 
> I have a proposal to replace the long keyword "subscript" with the shorter version, "subs". The idea is to keep the concise naming style on the language keywords, like "init" and "func".
> 
> So, Instead of:
> 
> subscript(index: Int) -> Int {
>         ... ...
> }
> 
> we could simply do:
> 
> subs(index: Int) -> Int{
>         ... ...
> }
> 
> Does this mean a big change on the parser side? what do you think?
> 
> Thank you!
>  _______________________________________________
> swift-evolution mailing list
> swift-evolution at swift.org <mailto:swift-evolution at swift.org>
> https://lists.swift.org/mailman/listinfo/swift-evolution <https://lists.swift.org/mailman/listinfo/swift-evolution>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20151210/dac15807/attachment.html>


More information about the swift-evolution mailing list