[swift-evolution] Proposal for Replacing Keyword "subscript" with "subs"‏

Feijian Sun feijian_sun at hotmail.com
Thu Dec 10 20:12:11 CST 2015

Hello, I have a proposal to replace the long keyword "subscript" with the shorter version, "subs". The idea is to keep the concise naming style on the language keywords, like "init" and "func".So, Instead of:subscript(index: Int) -> Int {        ... ...}we could simply do:subs(index: Int) -> Int{        ... ...}Does this mean a big change on the parser side? what do you think?Thank you!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-evolution/attachments/20151210/115b78eb/attachment.html>

More information about the swift-evolution mailing list