[swift-evolution] Introduce "associated_type" keyword

Dmitri Gribenko gribozavr at gmail.com
Sat Dec 5 20:20:18 CST 2015

On Sat, Dec 5, 2015 at 5:43 PM, Stephen Celis via swift-evolution
<swift-evolution at swift.org> wrote:
>> On Dec 5, 2015, at 8:11 PM, Kevin Lundberg via swift-evolution <swift-evolution at swift.org> wrote:
>> If we must keep this concept, I would prefer something without an underscore for the keyword, like "associatedtype" or perhaps "typeassociation"
> Or merely "associated".

+1 to the proposal, emphasizing the distinction is important; and I
like "associated" as the keyword for this purpose, too.


(j){printf("%d\n",i);}}} /*Dmitri Gribenko <gribozavr at gmail.com>*/

More information about the swift-evolution mailing list