[swift-dev] [semantic-arc][proposal] High Level ARC Memory Operations
atrick at apple.com
Fri Oct 7 23:25:48 CDT 2016
> On Oct 7, 2016, at 6:04 PM, Michael Gottesman via swift-dev <swift-dev at swift.org> wrote:
>> I wonder whether it might make more sense for load [borrow] to be a different instruction.
>> There's a couple reasons for that first. The first is that it's the only load which introduces
>> a scope, which is a really big difference structurally. The second is that it's the only load
>> which returns a non-owned value, which will be a typing difference when we record
>> ownership in the type system.
> I am fine with a load_borrow. If this is the only change left that you want can I just send out a proposal with that small change and start implementing. I am nervous about perfection being the enemy of the good (and I want to start implementing this weekend if possible *evil smile*).
There’s a lot in the proposal that makes sense to discuss for completeness but isn’t motivated by a particular need. Please separate functionality. We only need load [copy] at first right? When do those need to be promoted to load_borrow? load [trivial] is an optimization, so that should follow a functionally complete implementation. load [take] should definitely not exist until there’s some motivation.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the swift-dev