[swift-corelibs-dev] Building Foundation in Xcode

Brian Gesiak modocache at gmail.com
Sun Mar 13 14:34:29 CDT 2016

The repository has been migrated to Swift 3. You'll need a Swift 3 .xctoolchain to build it. There isn't a snapshot available yet, but you can build your own using the script added to Swift in https://github.com/apple/swift/pull/1630.
Even using the Swift 3 toolchain, I encountered build errors related to NSRunLoop. Applying https://github.com/apple/swift-corelibs-foundation/pull/284 got everything working for me.
Hope that helps!
- Brian Gesiak

On Sun, Mar 13, 2016 at 12:31 PM -0700, "David Hart" <david at hartbit.com> wrote:

Ok, I’m also encountering errors, but many more than Pushkar:OS: OS X El CapitanXcode: Version 7.3 beta 5 (7D162j)Toolchain: Xcode Swift DEVELOPMENT Snapshot 2016-03-01 (a)And the errors I’m getting seem to come from a mismatch with the Standard Library:Foundation/FoundationErrors.swift:10:48: Use of undeclared type ‘ErrorProtocol'Foundation/NSString.swift:1220:55: Use of undeclared type ‘CVarArg’Foundation/NSData.swift:18:38: Use of undeclared type ‘OptionSet’Foundation/NSNotification.swift:95:11: Use of undeclared type ‘Sequence' ...Any ideas what I’m doing wrong?
On 03 Mar 2016, at 20:01, Pushkar N Kulkarni via swift-corelibs-dev <swift-corelibs-dev at swift.org> wrote:
Brian, Philippe - Thanks for your prompt responses! 
You were right, I was using the 2016-02-08 toolchain. Using the latest (2016-03-01) solved the problem :)
Pushkar N Kulkarni,
IBM Runtimes
"Any sufficiently advanced technology is indistinguishable from magic." - Arthur Clarke

-----Brian Gesiak <modocache at gmail.com> wrote: -----To: <swift-corelibs-dev at swift.org>, Pushkar N Kulkarni/India/IBM at IBMIN
From: Brian Gesiak <modocache at gmail.com>
Date: 03/02/2016 11:26PM
Subject: Re: [swift-corelibs-dev] Building Foundation in Xcode

Hello Pushkar,
One idea that comes to mind: are you launching Xcode 7.2 using a recent Swift toolchain? To do so, follow the instructions on this page: https://swift.org/download/#latest-development-snapshots
Specifically, you'll want to launch Xcode using the xcrun launch-with-toolchain command.
Forgive me if this isn't the problem--I'm not at a computer right now, but that error message vaguely reminds me of what happens when one tries to build Foundatoon with an older version of Swift.
- Brian Gesiak

On Wed, Mar 2, 2016 at 8:09 AM -0800, "Pushkar N Kulkarni via swift-corelibs-dev" <swift-corelibs-dev at swift.org> wrote:

I am very new to Xcode and  tried building Foundation and running TestFoundation in Xcode 7.2.1, using the instructions given here.
In step 3, Foundation doesn't build because Xcode reports a compilation failure in NSObjCRuntime.swift (please refer to the attached snapshot):Use of unresolved identifier '_typeByName'
I can see that this function is defined outside of the Foundation project, in the swift project (stdlib/public/core/Misc.swift). I think there are other functions defined in the stdlib and used in Foundation. I am not sure why this particular symbol causes a problem.
Could someone please tell me how the symbol could be imported so that Foundation could be compiled and linked?

Pushkar N Kulkarni,IBM Runtimes "Any sufficiently advanced technology is indistinguishable from magic." - Arthur Clarke

swift-corelibs-dev mailing list
swift-corelibs-dev at swift.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-corelibs-dev/attachments/20160313/0e2636ab/attachment.html>

More information about the swift-corelibs-dev mailing list