[swift-users] Should I be using more catchless do blocks?

Geordie Jay geojay at gmail.com
Tue Jun 20 02:40:47 CDT 2017


Sorry in advance if Google Inbox messes with my code formatting below
(can't there be just one good email client? I miss Mailbox)

Michael Savich via swift-users <swift-users at swift.org> schrieb am Mo. 19.
Juni 2017 um 20:54:

> Yeah, it's all about balance to be sure. Though one benefit of do blocks
> is in functions that are tied to a sense of time. It seems to me that the
> in case of something like viewDidLoad separating code into too many
> functions can obscure the fact that the code is meant to be executed at
> that time.
>

In my experience, the most idiomatic and readable (and testable! if that's
important in your context) way of doing this is to create extensions to
group and encapsulate related functionality (example obviously won't
compile but hopefully you get what I mean):

```
extension MyViewController {
    override public func viewDidLoad() {
        let something = processModelData(data)
        let views = something.map { UIView($0) }
        addRelatedSubviews(view)
    }

    private func addRelatedSubviews() {...}
    private func processModelData() {...}
}
```

Closures can provide much of the same functionality but I'm pretty sure
> inline closures have to have names and sometimes risking a bad name is
> worse than no name at all.
>
> Anyway, do you think that most Swift users are even aware that do can be
> used in this fashion?
>

Yes, and sometimes it's useful, most of the time I've seen or used it
myself I'd consider it a code smell.

This is just a personal preference but I find that more indentation is
almost always harder to read than less. The aim is to reduce cognitive load
("Don't make me think").


>
> Sent from my iPad
>
> On Jun 19, 2017, at 2:33 PM, Michael Ilseman <milseman at apple.com> wrote:
>
> Introducing scope to manage lifetimes of local variables is a useful and
> valuable practice. Note that it might also be an opportunity to refactor
> the code. Any do block you want to introduce could also be a local function
> definition that you call later. Alternatively, it could be generalized and
> extracted into a utility component. Long function bodies with many do
> blocks could be a code smell.
>
>
> On Jun 18, 2017, at 7:07 PM, Michael Savich via swift-users <
> swift-users at swift.org> wrote:
>
> So, something I did not know until recently is that do blocks in Swift are
> for more than just error handling, they can also be used to tighten scope.
>
> I'm wondering, why *not* use a ton of do blocks? Like, if I have a
> ViewController lifecycle method like viewDidLoad, I could segment it into
> out a do block for creating subviews, a do block for loading data into
> them, and a do block for adding them to the view itself. This seems like it
> would enforce grouping code tightly together.
>
> Yes I could adopt a functional style of programming, but that has its
> downsides too, namely reading any functional code involves trawling through
> a long sequence of function calls. What I'm saying is, do blocks seem like
> a way to get many of the benefits of functional programming while
> maintaining the readability of imperative code. (Sorry functional
> programmers, I promise I love Haskell too!)
>
> So I guess what I'm saying is… somebody talk me down from this ledge. Is
> there a reason I *shouldn't *refactor my projects to be full of do
> blocks? And can this usage of do really be considered idiomatic Swift? Or
> will most people reading my code be left wondering where all the try and
> catch statements are?
>
> Sent from my iPad
> _______________________________________________
> swift-users mailing list
> swift-users at swift.org
> https://lists.swift.org/mailman/listinfo/swift-users
>
>
> _______________________________________________
> swift-users mailing list
> swift-users at swift.org
> https://lists.swift.org/mailman/listinfo/swift-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-users/attachments/20170620/3ff45e66/attachment.html>


More information about the swift-users mailing list