[swift-users] Segfault: 11 only when running tests (XCode 8, Swift 2.3)

Thomas Abend thomas at gethopscotch.com
Thu Oct 6 08:47:12 CDT 2016

Since moving a mixed Swift and Objective-c project to XCode 8 with Swift
2.3, I have been getting a "Command failed due to signal: Segmentation
fault: 11" error every time I run my tests after making a change in any of
the test files.

When I click on the error for more information I see:

<module-includes>:1:9: note: in file included from <module-includes>:1:
#import "Headers/Utilities.h"
/Users/.../Utilities.framework/Headers/Utilities.h:18:9: error:
include of non-modular header inside framework module 'Utilities'
#import <Utilities/NSString+Utilities.h>

And basically just a bunch of similar errors following that ending in:

<unknown>:0: error: could not build Objective-C module 'Utilities'

Utilities in this case is a framework that I made. All of the headers in
the Utilities.h file are imported with angle brackets and the headers are
marked as public.

After it segfaults, it will run properly until I make a change to the test
file. It only has this issue when testing, not when building or running.

Other things I've tried:

   - Changing the framework and tests to allow non modular includes
   - Enabling/disabling bitcode

Any help would be appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-users/attachments/20161006/979b3e45/attachment.html>

More information about the swift-users mailing list