[swift-users] Building Swift 3 under ArchLinux

Lukas Stabe ahti333 at gmail.com
Mon Jul 18 00:48:18 CDT 2016

I ran into the same error a few weeks ago. I can’t remember where I found this and why it fixes things, but this patch made swift build again for me:

diff --git a/cmake/modules/SwiftManpage.cmake b/cmake/modules/SwiftManpage.cmake
index 480b100..3bb1af3 100644
--- a/cmake/modules/SwiftManpage.cmake
+++ b/cmake/modules/SwiftManpage.cmake
@@ -30,7 +30,7 @@ function(manpage)
         "${POD2MAN}" "--section" "${MP_MAN_SECTION}"
-        "--center" "${MP_PAGE_HEADER}" "--release"
+        "--center" "${MP_PAGE_HEADER}"
         "--name" "${MP_MAN_FILE_BASENAME}"
         "${MP_SOURCE}" > "${output_file_name}”

I’m not familiar with pod2man, can someone more familiar shed some light on what this does and wether it could be fixed upstream?

— Lukas

> On 17 Jul 2016, at 21:58, Farhan Ahmed via swift-users <swift-users at swift.org> wrote:
> Thanks Kyle for the help and link to the swiftenv. I didn’t know it was available, and was wondering if there was one available… saves me the trouble of writing one ;)
> I have all dependencies installed. The error seems to be that the docs/tools/swift.1 file that is created is zero bytes, so I am thinking that that file should not be zero bytes… back to figuring out why that file is zero bytes.
> As an aside, to me this looks like it is trying to build docs or something non-essential, therefore why throw an error, and not a warning and continue with the build? (this is a question for you Swift build managers! … if anyone from there is reading this.) 
> Best,
> Farhan
>> On Jul 17, 2016, at 5:14 AM, Kyle Fuller via swift-users <swift-users at swift.org> wrote:
>> Hi Farhan,
>> To build Swift on ArchLinux you will need to install the perl package which includes pod2man. I think the list of dependencies at https://swiftenv.fuller.li/en/latest/building-swift.html#arch-linux is correct and should contain everything you need.
>>   $ pacman -S perl libbsd icu git libedit python2 clang make ninja
>> Hope this helps,
>> Kyle
>>> Hi,
>>> I am hoping someone would be able to help with the following problem:
>>> I am trying to build Swift 3 under ArchLinux. I have followed the build instructions and everything has been cloned and kick off the build by typing: ./swift/utils/build-script -R
>>> After a long while the build errors out at (emphasis mine):
>>> copying static files... done
>>> copying extra files... done
>>> dumping search index in English (code: en) ... done
>>> dumping object inventory... done
>>> build succeeded.
>>> [574/574] Generating swift.1
>>> FAILED: docs/tools/swift.1 
>>> cd /home/insha/build/Ninja-ReleaseAssert/swift-linux-x86_64/docs/tools && /usr/bin/core_perl/pod2man --section 1 --center Swift\ Documentation --release --name swift --stderr /home/insha/swift/docs/tools/swift.pod > /home/insha/build/Ninja-ReleaseAssert/swift-linux-x86_64/docs/tools/swift.1
>>> Can't open swift: No such file or directory at /usr/bin/core_perl/pod2man line 70.
>>> ninja: build stopped: subcommand failed.
>>> ./swift/utils/build-script: fatal error: command terminated with a non-zero exit status 1, aborting
>>> So what am I doing wrong? What can I do to either fix this issue or skip it if it is not essential (i.e. docs, etc.)? Any help and pointers would be greatly appreciated.
>>> Best,
>>> Farhan
>> _______________________________________________
>> swift-users mailing list
>> swift-users at swift.org
>> https://lists.swift.org/mailman/listinfo/swift-users
> _______________________________________________
> swift-users mailing list
> swift-users at swift.org
> https://lists.swift.org/mailman/listinfo/swift-users

More information about the swift-users mailing list