[swift-users] Swift Package Manager not creating library (.a) files

Michael Brown me at michael-brown.net
Fri Feb 26 12:40:06 CST 2016


I tried using the Swift Package Manager for the first time today. I was trying to adapt a library I'm working on to support it. When I run "swift build" it builds, but there is no .a file anywhere in the .build directory tree. All I get is a .swiftmodule file.

In case I had something wrong setup in my library, I downloaded the SPM example (https://github.com/apple/example-package-playingcard <https://github.com/apple/example-package-playingcard>) and tried to build that. According to the documentation here (https://swift.org/package-manager/#example-usage <https://swift.org/package-manager/#example-usage>) this should produce a .a file in the root of the .build/debug directory. It doesn't. There is no .a file anywhere, only a .swiftmodule file. By the way, the documentation is out of date as the intermediate build .o files are now in a <modulename>.build directory, not at the root of .build.

I'm using the latest development snapshot downloaded from swift.org <http://swift.org/>.

- Michael.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.swift.org/pipermail/swift-users/attachments/20160226/fdb80e33/attachment.html>

More information about the swift-users mailing list